Recent changes to news

Recent changes to news

  • Fix WantedPages for Fusionforge
  • Remove WantedPagesOld (use WantedPages instead)
  • Add WebM format in Video plugin
  • Update jscalendar to 1.0
  • Remove Width and Height preferences modification in Edit Toolbar
  • New icons in Edit Toolbar
  • Make static templates in Edit Toolbar work
  • Fix memory_limit for WIKI_SOAP
  • Remove MockRequest
  • Update jquery to 1.11.3

This is a bug-fix and enhancement release.

  • Fix Bug#648 Call to protected method
  • easier file upload: forbidden characters in filename are replaced by dashes (instead of rejecting upload)
  • improve handling of image insertion icon in edit toolbar (icon did not always appear after image uploading)
  • bigger wikipaging font
  • test again for function 'posix_times', it does not exist on Windows (reported by jdebert)
  • remove FPDF, lib/gif.php, lib/font (were not used)
  • rename plugin _Retransform to DebugRetransform
  • use PHP ZIP class instead of home-made functions. ziplib renamed to mimelib
  • add SOAP scripts
  • rename FCKeditor to CKeditor
  • load theme pgsrc, if it exists
  • SUBPAGE_SEPARATOR removed, it must be '/'
  • RateIt plugin for Fusionforge
  • remove acdropdown and livesearch
  • remove CVS backend

This is a security fix release.
* Fix CVE-2014-5519: vulnerability in Ploticus plugin.http://www.cvedetails.com/cve/CVE-2014-5519/

This is a bug-fix release.

  • fix Bug#456 'Optimizing Database' message sometimes printed on page
  • remove FrameInclude plugin (frames are not supported in HTML 5)
  • sort tables with tablesorter jQuery plugin instead of sortable.js
  • fix Bug#636 Recursive include is not trapped
  • fix Bug#647 undefined method WikiDB_backend_dba::WikiDB_backend_dbaBase
  • correct total number of pages for AllPagesCreatedByMe, AllPagesOwnedByMe, AllPagesLastEditedByMe
  • fix Bug#607 BackLinks do not work inside a [[Help:RichTablePlugin|RichTable]]
  • fix Bug#646 Wrong number of links in BackLinks
  • make<includeonly> work
  • remove old WikiUser code (ENABLE_USER_NEW)
  • admin always has rights to see and modify pages, regardless of ACLs, to avoid locking himself out
  • add missing images in Sidebar theme
  • PhpWiki 1.5.0 needs at least PHP 5.3. It is compatible with PHP 5.3, 5.4 and 5.5.
  • One single wiki markup, based on Wikicreole and compatible with classic phpWiki markup.
  • Full HTML 5 and CSS 3. A modern browser is needed.
  • Full UTF-8.

PhpWiki 1.4.0 is the same as PhpWiki 1.4.0RC1. It is the last release compatible with PHP 4.

PhpWiki is a WikiWikiWeb clone in PHP. A WikiWikiWeb is a site where anyone can edit the pages through an HTML form. Multiple storage backends, dynamic hyperlinking, themeable, scriptable by plugins, full authentication, ACL's.PhpWiki 1.2.11 adds small fixes from user patches. I just forgot to release them in the last years, sorry.* support remove for $WhichDatabase = file* date => strftime by Pavel Zaichenko* localizable pcre_fix_posix_classes by Pavel Zaichenko,make A& I word-begin english specific* added russian locale by Pavel Zaichenko* added chinese locale by ShiningRayhttp://sourceforge.net/project/showfiles.php?group_id=6121&package_id=14187&release_id=585044Note that 1.2.x is the old-stable branch, which is not in active development since 2001 anymore. 1.3.x is the active branch with all the features.
1.3.14If you use LDAP authentification this fixes the fix from 1.3.13 and 1.3.13p1.Plus it contains some new stuff.fixes:* Fix the broken LDAP fix from 1.3.13p1* fixed sortby with multiple pagelistschanges:* changes all themeinfo.php files, moved global to method load() to beeasier derived from custom theme classes, main now calls $WikiTheme->load* MailNotify is now silent unless DEBUGnew:* added experimental ATOM support* added Changes and Upload button to editFull ReleaseNotes + ChangeLog:http://phpwiki.cvs.sourceforge.net/phpwiki/phpwiki/pgsrc/ReleaseNotes?revision=1.76&view=markupDownload (.tar.bz2 or .zip or changes only .zip):http://sourceforge.net/project/showfiles.php?group_id=6121&package_id=31289&release_id=520021
1.3.13 patchset 1If you use LDAP authentification this is an important security fix for 1.3.13.Plus it contains some minor fixes:* fix action=upgrade for dba, rename nosql to nodb* fixes SpamBlockList config file locations (config/two-level-tlds, config/whitelist)* enable $MailNotify->onChangePage* fix display of pagenames containing":" in certain lists* fixed backend asArray access to iterators (DebugInfo with SQL)* and some pgsrc fixesFull ReleaseNotes + ChangeLog:http://phpwiki.cvs.sourceforge.net/phpwiki/phpwiki/pgsrc/ReleaseNotes?revision=1.75&view=markupDownload (.tar.bz2 or .zip or changes.zip):http://sourceforge.net/project/showfiles.php?group_id=6121&package_id=31289&release_id=514820
After more than one year intensive work we are proud to release the next version.This is major feature release which will be the base for the stable 1.4.0. The highlights are SemanticWeb support, basic support for various WYSIWYG editors (not yet stable), a stable MonoBook (wikipedia) and blog theme, enabled acdropdown support (LiveSearch), postgresql and oracle enhancements, moving Help pages into Help/, support different charsets in pgsrc and Windows NTLM auth support via HttpAuth, a lot more plugins and enhancements. UTF-8 should work.ReleaseNotes + ChangeLog:http://phpwiki.cvs.sourceforge.net/phpwiki/phpwiki/pgsrc/ReleaseNotes?revision=1.74&view=markupDownload (.tar.bz2 or .zip):http://sourceforge.net/project/showfiles.php?group_id=6121&package_id=31289&release_id=511850

lib/CachedMarkup.php (In template 'browse' < 'body' < 'html'):499: Notice: Only variables should be assigned by reference

lib/DbaDatabase.php:134: Warning: dba_replace() [<a href='function.dba-replace'>function.dba-replace</a>]: You cannot perform a modification to a database without proper access